[ale] FW: ATAPI woes (Slackware 3.0)

Corbie corbie at infinet.com
Sun Oct 20 13:58:59 EDT 1996

The following is a transcript of a reply I recieved from another mailing 
list regarding an install problem I'm having, as well as my follow-up.  Any 
ideas out there in Georgia?

>You're very close.  The Boca IDE controller contains The primary (1F0)
>and secondary (170) ATA interfaces.  The ATA interface on the sound
>card is the 3rd ATA interface (1e8).  So try:
>boot:  ramdisk ide2=0x1e8,0x3ee,11
>Only the first two ATA interfaces are probed automatically, so that's
>why you need this kernel parameter.

I re-checked, and I've already tried that with no change in the problems; 
but thanks.  I've tried ide0-3, actually.

In summary, /dev/hda is a Conner 1.275GB drive, and the boot sector is 
'infected' with their overlay software since I don't have LBA in my 
motherboard nor the Boca hard drive controller I have installed.  /dev/hdb 
is a WD 420MD drive, which is where I'm trying to put Linux.  Ideally, I 
want to be able to boot the Linux drive without resorting to a boot floppy, 
and to be able to mount the DOS/Win95 partition that comprises /dev/hda 
from within Linux so I can share files when desired.  And since my 
controller only supports two IDE devices, the CDROM (Creative Labs X4) is 
linked into the IDE/ATAPI interface of a Genius PnP soundcard.

Unfortunately, Linux calls /dev/hda's boot sector corrupted, so LILO won't 
even think about installing, nor can any part of the partition be seen from 
Linux.  And using a boot floppy and every boot parameter I've been able to 
find on scads of how-to files, in a seemingly infinite array of 
combinations, gives me (at best) errors such as unable to read CDROM 
format, or no CDROM present, or whatever.  At worst, the boot-up goes into 
an infinite loop of trying to find the CDROM and timing our, or I get 
kernel panics.

I've tried using just the A, AP, K and Q disk suites (can't do fewer and 
still be able to compile one of the kernels) and re-compiling the kernel. 
 No change.

I've tried loading from LOADLIN and using one of the boot images from the 
Slacksare 3.0 CD.  LOADLIN won't recognized any of them.  I've tried 
re-naming zImage to vmlinuz, copying it to a dinky DOS partition on the 
420MB drive (which Linux /can/ see) and trying to boot from Win95 (in DOS 
mode).  Zip.

The latest version of the kernel available on the CD is 1.3.20.  I've 
downloaded 2.0.23 but it won't even compile.

Is there some way, any way, to use a large IDE drive with the overlay 
software intact, and to used the CDROM over the soundcard socket?  If so, 
are these solutions actually documented somewhere?  (Try even finding a 
LILO or LOADLIN how-to that's not a couple of years old, and/or has 
complete information.  I've been unable to.  Nor do either of Welsh's books 
help, nor the Volkerding book, nor the huge QUE book.  I've bought all 
four.)  To tell truth, after  many late nights reading unhelpful how-to 
files and trying endless combinations of failed configurations based on 
those files, I'm beginning to wonder why I bothered.

Thanks in advance.
                       Mark Dyson  --  mdyson at poboxes.com
"Modern morality and manners suppress all natural instincts, keep people
 ignorant of the facts of nature and make them fighting drunk on bogey 
        --  Aleister Crowley

More information about the Ale mailing list