Problem installing Slackware 2.1.0 ('bare' hangs)

Byron A Jeff byron at
Wed Jan 4 08:11:00 EST 1995


You should join ALE - Atlanta Linux Enthusiasts. This local organization
with a large Tech component could be of great help to you.

In article <3ed7bn$g1p at> you write:
>I'm trying to install Slackware 2.1.0, but the bootdisk--I'm using 'bare'--
>hangs somewhere in the boot sequence.  Transcript follows:
>ftape: allocated 3 buffers aligned at: 001b8000
>Calibrating delay loop.. ok - 2.52 BogoMips
>Memory: 5528k/8192k available (592k kernel code, 384k reserved, 1688k data)
>Floppy drive(s): fd0 is a 1.44M
>FDC 0 is a 8272A
>Swansea University Computer Society NET3.017
>Swansea University Computer Society TCP/IP for NET3.017
>IP Protocols: ICMP, UDP, TCP
>Checking 'hlt' instruction... 
>and then nothing happens after that.
>My system setup is plain vanilla:
>386sx, 20MHz, 8Mb RAM  (might not be an Intel chip;  Deico, I think, or did
>                        they just license the chip from Intel?)
>1 floppy, IDE, 1.44 Mb 3.5"
>1 120Mb Maxtor 7120A (?) HD (IDE)
>1 43Mb Seagate ???? HD (IDE)
>and of course the usual extras:  mouse, internal modem, and Cirrus VGA 
>card (but alas, no CD-ROM).
>I tried the bare diskette on another computer (486/33:  Don't know all the 
>specs on it, but it's all IDE, too, I think.)  I've also tried downloading
>and rawriting another copy of the disk.  This did not help.  I've read 
>faqs and HOWTOS galore,and the Installation Guide from Matt Welsh.  (Please 
>don't tell me to RTFM unless you can give me an idea _which_ FM addresses 
>this problem.)  If anyone has any ideas at all, please, PLEASE help.  I wel-
>come any enlightenment whatsoever as I am total Linux newbie (surprise, sur-
>prise), though I have had a little experience with other Unix systems.

You've done everything right. If you get exactly the same result on the
486-33 then it's probably the floppy. from my bootup list Linux seems to
check the disk partitions after the halt instruction. But from experience
if a linux boot disk fails on 2 different machines then it's probably the

Are you downloading directly via modem? If so try this experiment that
I've been working on for getting Linux on a floppy-less machine:

1) ftp loadlin1.5.tgz from
2) Install loadlin and the bare kernel on a DOS partition of your machine.
3) Boot the linux kernel from DOS using loadlin. This bypasses the floppy
   so you can see if the floppy is the cause.

In any case keep us posted by mailing to ale at Can someone
describe the process to subscribe to the list?

Don't give up. We're here to help.


Another random extraction from the mental bit stream of...
Byron A. Jeff - PhD student operating in parallel - And Using Linux!
Georgia Tech, Atlanta GA 30332   Internet: byron at

More information about the Ale mailing list